Thread Rating:
  • 5 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Guide] How to create c12 encoding quality. Now with Video Tutorial
Information 
I'm just going to make a google index for how to run MeGUI in Linux (Tested in latest Debian Stretch, with latest kernel and header)
[Image: Screenshot_2018-04-19_08-34-02.png]

This is how the output looks like (sample): https://zerobin.net/?2c53624ca6bb8a66#ql...q3SutTRhc=


Known problem (and easily fixed with Take Ownership with Powershell)
[Image: Screenshot_2018-04-19_08-36-47.png]

Summary:
  1. Get VMware 14 for linux. install it with latest kernel, header, and gcc build-essentials
  2. Get Windows 8.1 x64 Pro. Put it
  3. The test devices was run with virtual setting: 4 Core, 2GB RAM, 20GB Disk, NAT Adapter, Shared Folder to Host, additional USB Controler support
  4. once the machine boot and vm-tools finished installing. Pasta your megui folder to C:\Program Files\megui, take ownership recursively
  5. Run it
  6. ????
  7. Profit
Note: Questions & Suggestion are open (Just jump up in our discord). Trivial question like how2use linux or how2install package and similiar are ignored. This is supposed for advanced user, not linux illiterate


Credits to Ely Sion#9223 for bringing up some guy request and thank you Yvonne Langfeldt#7636 for lending me this VM | Archive
Reply
(19 April 2018, 01:31 PM)Internet Explorer Wrote: I'm just going to make a google index for how to run MeGUI in Linux (Tested in latest Debian Stretch, with latest kernel and header)

...

Good work and thank you for your effort. logged in with root account like a madman 5/7 don't do that at home My Side

if you got more time to waste probably could do with few minor adjustment (such as turning off certain windows feature and useless services), picking 32bit base (but yea the vmware only support 64bit in latest releases) even tho it won't make much difference. Virtual-X any Hyper-V should be out of question knowing how trivial they are.

i'll overlook this. should be great if someday we got optimized version of windawgs with solely purpose to run megui inside it (probably with some support tools such as OCR, subbing things, rescue software in case the windows fail to recognize certain files). not so soon but slowly i will  Big Smile

[!] Found a dead lynx link? Report!
[!] Want different mirror? just ask

Let's go P2P? | Discord
Reply
Hey i have created config for handbrake which is on par with megui settings (i literally just setting it here and there). The visual is okay, but the audio is not really good, Especially on high/low frequency.

Here it is : Mega
Below is peek into the JSON
Code:
{
  "PresetList": [
    {
      "AudioCopyMask": [],
      "AudioEncoderFallback": "av_aac",
      "AudioLanguageList": [
        "jpn",
        "und"
      ],
      "AudioList": [
        {
          "AudioBitrate": 48,
          "AudioCompressionLevel": 0.0,
          "AudioDitherMethod": null,
          "AudioEncoder": "av_aac",
          "AudioMixdown": "mono",
          "AudioNormalizeMixLevel": false,
          "AudioSamplerate": "auto",
          "AudioTrackQualityEnable": false,
          "AudioTrackQuality": 5.0,
          "AudioTrackGainSlider": 5.0,
          "AudioTrackDRCSlider": 2.5000000000000004
        }
      ],
      "AudioSecondaryEncoderMode": true,
      "AudioTrackSelectionBehavior": "first",
      "ChapterMarkers": false,
      "ChildrenArray": [],
      "Default": true,
      "FileFormat": "av_mp4",
      "Folder": false,
      "FolderOpen": false,
      "Mp4HttpOptimize": false,
      "Mp4iPodCompatible": false,
      "PictureAutoCrop": true,
      "PictureBottomCrop": 0,
      "PictureLeftCrop": 0,
      "PictureRightCrop": 0,
      "PictureTopCrop": 0,
      "PictureDARWidth": 0,
      "PictureDeblock": 4,
      "PictureDeinterlaceFilter": "decomb",
      "PictureCombDetectPreset": "default",
      "PictureCombDetectCustom": null,
      "PictureDeinterlacePreset": "default",
      "PictureDeinterlaceCustom": "",
      "PictureDenoiseCustom": "",
      "PictureDenoiseFilter": "off",
      "PictureDenoisePreset": "medium",
      "PictureDenoiseTune": "none",
      "PictureDetelecine": "default",
      "PictureDetelecineCustom": "",
      "PictureItuPAR": false,
      "PictureKeepRatio": true,
      "PictureLooseCrop": false,
      "PictureModulus": 2,
      "PicturePAR": "auto",
      "PicturePARWidth": 0,
      "PicturePARHeight": 0,
      "PictureRotate": "0:0",
      "PictureWidth": 1280,
      "PictureHeight": 720,
      "PictureForceHeight": 0,
      "PictureForceWidth": 0,
      "PresetDescription": null,
      "PresetName": "Animegrimoire",
      "Type": 1,
      "UsesPictureFilters": false,
      "UsesPictureSettings": 1,
      "SubtitleAddCC": true,
      "SubtitleAddForeignAudioSearch": false,
      "SubtitleAddForeignAudioSubtitle": false,
      "SubtitleBurnBehavior": "foreign_first",
      "SubtitleBurnBDSub": false,
      "SubtitleBurnDVDSub": false,
      "SubtitleLanguageList": [
        "eng",
        "und"
      ],
      "SubtitleTrackSelectionBehavior": "first",
      "VideoAvgBitrate": 550,
      "VideoColorMatrixCode": 0,
      "VideoEncoder": "x264",
      "VideoFramerate": "30",
      "VideoFramerateMode": "pfr",
      "VideoGrayScale": false,
      "VideoHWDecode": false,
      "VideoScaler": "swscale",
      "VideoPreset": "veryslow",
      "VideoTune": "animation",
      "VideoProfile": "main",
      "VideoLevel": "4.1",
      "VideoOptionExtra": "deblock=0,0:bframes=5:ref=10:qpmin=10:qpmax=51:vbv-bufsize=78125:vbv-maxrate=62500:aq-mode=2:subme=7:trellis=1",
      "VideoQualityType": 1,
      "VideoQualitySlider": 22.0,
      "VideoQSVDecode": true,
      "VideoQSVAsyncDepth": 4,
      "VideoTwoPass": true,
      "VideoTurboTwoPass": true,
      "x264Option": "",
      "x264UseAdvancedOptions": false
    }
  ],
  "VersionMajor": "11",
  "VersionMicro": "0",
  "VersionMinor": "0"
}
¯\_(ツ)_/¯
Reply
if i remember correctly, handbrake use faac for mp4 which is good at exact 128kbps, but bad at other bitrate, low and even high (animegrimoire 48kbps?)
Reply
(29 April 2018, 01:21 AM)hollowrem Wrote: if i remember correctly, handbrake use faac for mp4 which is good at exact 128kbps, but bad at other bitrate, low and even high (animegrimoire 48kbps?)

nope, we're on 32kbps. also the 128kbps part is true.
other than faac, opus is viable alternative too


(22 April 2018, 02:13 PM)Lynx Wrote: Hey i have created config for handbrake which is on par with megui settings (i literally just setting it here and there). The visual is okay, but the audio is not really good, Especially on high/low frequency.

...

here it is how it looks when it ported to handbrake linux ver

IMO you should have to decide to elevate the maximum audio bitrate to 128kbps

Pros:
  1. we done having a good handbrake preset, cross-platform while you're on it
  2. way better audio quality. I've tested how is it differ 32kbps compared to 128kbps on various devices (from phone built-in speaker, laptop built-in speaker, various sennheiser headphone, till whatyoucancall those speaker that using canned soda as case(?)).
Cons:
  1. filesize are increased by 5 mega bit

our 24min releases are pretty much 99Mb~106Mb. i'd bet that some +5mb are nothing, compared how guud dem audio in your ears are

also by Leanne said that she won't follow in handbrakes for some reason and went for customizing VM instead, you just gonna need to tell the forum when you decide, she'll follow you & update the latest megui archive using latest preset anyway
Reply
i'm going to purpose tweaked animegrimoire.json Big Smile 

Sample output:Dropbox
Reply
Stuck. Need help on the following error for the movie gotten from https://nyaa.si/view/1025911

[Image: H7RcdbN.jpg]

[Image: jpu7kRR.jpg]
Reply
(03 May 2018, 04:28 AM)cyber222 Wrote: Stuck. Need help on the following error for the movie gotten from https://nyaa.si/view/1025911

[Image: H7RcdbN.jpg]

[Image: jpu7kRR.jpg]

uhh this is the NeroAAC error while trying to parse sample rate, not megui itself

1. Encode your files separatedly.
   - Poke [Queue] on each Video and audio field, it'll make separated process
2. Make sure your MeGUI audio encoder setting is forcing the output into stereo channel

if forcing to stereo in separated process still fail, consider to

  1. use OPUS option for audio encode, import the preset from here
  2. use TAC from here. try to cut off the audio sample rate (if you need reference, try to peek at HS audio). put the audio output afterward in megui for animegrimoire's AAC, and then mux them manually in last step

let me know how it goes (IIRC TAC doesn't got preset thing but i could show you how it done if some alternate above doesn't werks

(01 May 2018, 07:24 AM)Internet Explorer Wrote: i'm going to purpose tweaked animegrimoire.json Big Smile

Sample output:Dropbox

i have no objection for 128kbit audio. you can't prove it were worse than 32kbit anyway.
if you were hesitate, make entire releases with both 128kbit and 32kbit, make the forum vote it within month,  call it a day

as for handbrake, yes i'll ignore it for time being, i see no pros using it compared to MeGUI (especially from personal preferences). as for VM (with preinstalled megui, handbrake, and tools for encoding-related and subbing) i'll definitely release it even it was ridiculously stupid idea.
if it looks stupid but it works, it's ain't stupid

[!] Found a dead lynx link? Report!
[!] Want different mirror? just ask

Let's go P2P? | Discord
Reply
(03 May 2018, 01:26 PM)Legendary Aurora Wrote:
(03 May 2018, 04:28 AM)cyber222 Wrote:
Show ContentSpoiler:

uhh this is the NeroAAC error while trying to parse sample rate, not megui itself

1. Encode your files separatedly.
   - Poke [Queue] on each Video and audio field, it'll make separated process
2. Make sure your MeGUI audio encoder setting is forcing the output into stereo channel

if forcing to stereo in separated process still fail, consider to

  1. use OPUS option for audio encode, import the preset from here
  2. use TAC from here. try to cut off the audio sample rate (if you need reference, try to peek at HS audio). put the audio output afterward in megui for animegrimoire's AAC, and then mux them manually in last step

let me know how it goes (IIRC TAC doesn't got preset thing but i could show you how it done if some alternate above doesn't werks
"Make sure your MeGUI audio encoder setting is forcing the output into stereo channel" eliminates the error. I am using the old audio encoder setting "Nero AAC: Cyber12".  When I switch to "Nero AAC: Animegrimoire (Stereo Downchannel)" setting that I copied from your backup months ago, the audio encoding becomes successful.  I did not encode the files separately though Big Smile . Thank you very much!
Reply
(03 May 2018, 03:21 PM)cyber222 Wrote: ...
When I switch to "Nero AAC: Animegrimoire (Stereo Downchannel)" setting that I copied from your backup months ago, the audio encoding becomes successful.  I did not encode the files separately though Big Smile . Thank you very much!

glad it worked, and you're welcome   Big Grin

[!] Found a dead lynx link? Report!
[!] Want different mirror? just ask

Let's go P2P? | Discord
Reply




Users browsing this thread: 1 Guest(s)